+ Reply
Page 1 of 4 1234 LastLast
  1. #1
    Master Onion
    Joined
    Apr 2002
    Location
    UK
    Posts
    6,327

    What 4870x2 problems do you have?

    This card is killing me. I have never had so many issues with a card. So far in the near 2 weeks of testing I havent done too much but:

    DIRT- Updated to recent patch which helped prolong the problem but still, I play the game for a few races and at some stage the fps plummets (e.g. from its normal 50-75 area to 30-45 area). Only fixed by reloading the game as far as i can tell. Try disabling catalyst AI (which is meant to make it run one core) which was recommended but didnt help.

    Bioshock- Questionable fps, its high, but not as high as I feel it should be compared to some reviews. Also suffers from a drop of fps if i die and reload *BAM!* goes my fps, also seen this issue happen after just playing the game a while. Again fixed by quiting game to desktop and reloading.

    UT3- Crashes when i try to load a game.

    (Added 05/09) Quake 4- Crashes when i try to load a game.

    GRID demo- Poor fps regardless of drivers, around the 35-60 area and this is with 1920x1200 with 4xAA, let alone same Resolution with 8xAA which reviewers are managing around 100fps on average. This problem is with version 1.0 and 1.1. Also some drivers causes screen flickering (fixed with vsync), and latest 8.8 finals cause cars to flicker.

    Furmark- Yep, i know its only a demo and not that important but still, runs fine with 8.5's, but fps halves with 8.8beta and finals.

    Aquamark- Yep, another insignificant demo really but it runs very badly then just errors at end.

    Just a random weird issue, when i first boot up core 1 seems to have temperatures that it gets when its loaded, whil'st core 2 is at idle temps. I have left it 5 mins and it still remains at these high temps. Fixes itself if i run a 3d program for 2 secs (e.g. run nature on 3dmark) and that seems to then allow it after to go to idle temps. This problem doesnt happen after that.

    On the subject of temps, they are completely fine, everything in the case is cooled nicely from a cosmos S with 7 case fans. I have tried lowering my cpu/memory clocks but doesnt help any problems. The 3 sets of drivers all been tested (8.5, 8.8 beta, 8.8 finals), and problems still with all.

    Some things seem to be working fine, 3dmarks do, Crysis does, Fear does, COD4 does. Not seen any issues with these so far, they all seem to run like the reviewers get them to run. This all just points to it all been card/driver issues.

    Only thing that has changed in my system at the same time as the card was a psu. I swapped my Enermax 620w noisetaker and added Corsair HX 1000w.

    Not had any of the above issues with my 8800GTX.

    I need to do more testing and hope another driver or two comes out to test, but im seriously so far considering selling this thing already. Not much point of a 350 card that runs somethings for 5-15 mins and then gives me same fps my 8800gtx did(worth 100) and other programs it runs just plainly badly if at all (UT3).

    What issues you guys having? Can anyone relate to any of my issues above? Anyone know how to fix anything? Its so frustrating having waited 20 months for a new card worth buying only for it to be inconsistent arse to run.

    Can you please keep flaming out/to a minimum in regards to ATI/nvidia. Its not going to help the issues above so not needed.

    EDIT: Forgot to include another random weird issue. With the 8.8 finals instaled strangily it will start up 3dmark06 on its own accord when i first turn it on. Its happened twice during the time i had them instaled, very weird.
    Last edited by JonnyG; September 5, 2008 at 20:15.

  2. #2
    Junior Member
    Joined
    Aug 2008
    Posts
    35

    Re: What 4870x2 problems do you have?

    I feel for you, I had problems just like yours too as well as others, I tored my self apart trying to fix it, format's, tweaks, trying the card on mates system the lot,I done everything you could think of, but to no avail, it turns out it was just the drivers, but I waited long enough and your not the only one my friend, there's quite a few of us who have been or are in the same boat as you and it's a damn shame. You could wait a bit longer and hope there's better driver released but I ended up taking the card back the other day and going to order a GTX280, I will just use this 3870(back up gpu) meanwhile.....

    Quote Originally posted by JonnyG View Post

    Can you please keep flaming out/to a minimum in regards to ATI/nvidia. Its not going to help the issues above so not needed.
    Am afraid this is likely to happen, there's a few ATI fan boys on here who cannot accept that the problems are due to drivers or the card and will flame like mad on this thread no doubt, and after I just explained my situation it's bound to happen, pull up the fences and grab some popcorn and coke and enjoy the show.
    Last edited by JOMOX; August 28, 2008 at 23:21.

  3. #3
    Junior Firefly
    Joined
    Apr 2002
    Location
    Bristol UK
    Posts
    583

    Re: What 4870x2 problems do you have?

    Quote Originally posted by JonnyG View Post
    GRID demo- Poor fps regardless of drivers, around the 35-60 area and this is with 1920x1200 with 4xAA, let alone same Resolution with 8xAA which reviewers are managing around 100fps on average. This problem is with version 1.0 and 1.1. Also some drivers causes screen flickering (fixed with vsync), and latest 8.8 finals cause cars to flicker.
    Is this a 4870x2 problem? I've got a single 4870 and was very impressed when I ran the demo yesterday at 1680x1050 with 8xAA and it didn't really go below 70fps. I'm using 8.7s BTW.

    I can relate to how you feel though, it's the same way I felt when I first had my 8800GTX. Vista was new then as well but for ages I was having problems, and new drivers often made things worse. I stuck with it though and it ended up being a fantastic card. But I was so close to listing it on ebay many times. Hope you get your issues sorted out mate, one way or another.

  4. #4
    Junior Master Onion
    Joined
    Mar 2007
    Location
    Australia, NSW, Lake Macquarie
    Posts
    5,504

    Re: What 4870x2 problems do you have?

    My mates got a HD4870 X2 and said he's has no problems. He had some issues with the 8.8s with a few BSODs apparently so he reverted back to default/CD drivers and now he's running all his games maxed out and telling me the framerate never drops below 60fps.

    I guess your got a bodgy card or something is conflicting with the card.

  5. #5
    Firefly
    Joined
    May 2003
    Location
    Lisbon , Portugal
    Posts
    852

    Re: What 4870x2 problems do you have?

    Untill now the only thing i have to point out is the insane heat this baby does cant w8 for the dam waterblocks for it start coming out comparing this to my 8800Gts 512 its a beast monster speed , you may be right about furmark etc but even with driver problems it shows its realy a power house, makes me wonder what can ATi driver team pull out with a good driver hey .

  6. #6
    Junior Onion
    Joined
    Feb 2008
    Location
    United Kingdom
    Posts
    2,666

    Re: What 4870x2 problems do you have?

    There are quite a few issues with the catalyst drivers and 48x currently. I get CTD with any quake based game if I enable triple buffering and in game vsync unless I set vsync to always on in CCC. In UT3 engines, I get issues with AA not being enabled for the whole scene, some parts are ok and others are not. Also the damn fan speeds up and slows down all the time between 1000 and 1400rpm which drives me nuts!

    But according to some, all these are user errors and lack of experience even though we have all owned high end cards previously... I was also advised that we should check if we have set the correct aspect ratio for the monitor, and make sure windows is installed in a certain order

    Anyway, rant over the beta 8.54 are "supposed" to fix a few issues with xfire. But be warned they are almost impossible to remove, and make it also impossible to roll back to 8.7 drivers in my case.

    http://www.rage3d.com/board/showthread.php?t=33929301

  7. #7

    Re: What 4870x2 problems do you have?

    The only problem i have gotten is the white dots on walls in crysis when using all settings on very high.

    UT3 works like a charm, haven't gotten any crashes yet.

    Bioshock, just installed the game and played it for about 30-40 min and never drops below 60fps (vsync)

    haven't tried grid, so i don't know about that game.

    Do you know that you should stay with the CD drivers from the beginning and not update before the 8.9 drivers? because the 8.8 doesn't support the 4870X2

    Haven't encountered the fps drop problem in dirt so far, is it map specific?

    Running on 1920x1200 with 2 AA and 16 AF with standard cat AI. exept for crysis, which runs 1920x1200 0 AA 8 AF.

    i guess (and hope) that the 8.9 drivers will fix most of the 4870X2 problems. But we know the ati driver team :P

    Edit: i haven't heard the noise either which people complain about (both the fan noise and the pitching sound)
    Last edited by kevin9915; August 29, 2008 at 01:50.

  8. #8
    Junior Firefly
    Joined
    Nov 2004
    Posts
    769

    Re: What 4870x2 problems do you have?

    Just got my 4870x2 yesterday only hit 2 problems testing it with god knows how many games and that was.

    When installing the 8.54 beta's screen blacked out and didn't recover.

    Running extended monitor to my 2nd LCD I sometimes get a system lock when exiting fullscreen apps (20% of the time maybe) - disabling second monitor cures it completely.

  9. #9

    Re: What 4870x2 problems do you have?

    Have to say that I haven't really had any problems with it so far - any I have seen are the usual corrupted textures you see in any GPU that are always fixed with a driver release...

    ICE

  10. #10
    Junior Firefly
    Joined
    Jan 2002
    Location
    United Kingdom
    Posts
    774

    Re: What 4870x2 problems do you have?

    Apart from getting flickering (horizontal bars scrolling up the screen) in COD4 and a little bit in crysis (fixed by turning on vsync) I haven't had any problems. I am using the 8.8 Betas still as the final 8.8's lost me performance.

    I didn't get ANY driver disk with my card (Powercolor) can someone post me a link to some legit drivers?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts