1. #1
    Junior Onion
    Joined
    May 2002
    Location
    London, UK.
    Posts
    2,236

    Linux Server not booting.

    Any Linux guru's still at FM?

    My linux skills are weak. We have a box at work that will not boot. The error is

    Code:
    init: relocation error: /lib/tls/libc.so.6: symbol _dl_starting_up, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
    
    Kernal Panic: Attempted to kill init!

  2. #2
    Master Onion
    Joined
    Jul 2001
    Location
    Saskatchewan, Canada
    Posts
    5,923

    Re: Linux Server not booting.

    Looks like your glibc installation is messed up somehow.

    Try booting from some rescue media and reinstall glibc and gcc.

  3. #3
    Junior Onion
    Joined
    May 2002
    Location
    London, UK.
    Posts
    2,236

    Re: Linux Server not booting.

    Quote Originally posted by Mohrk View Post
    Looks like your glibc installation is messed up somehow.

    Try booting from some rescue media and reinstall glibc and gcc.
    i have booted from a ubuntu live cd. How would I go about reinstalling glibc and gcc on my RHEL partition?


    Thanks.

  4. #4
    Super Moderator
    Joined
    Jun 2001
    Location
    Adelaide, Australia
    Posts
    6,551

    Re: Linux Server not booting.

    You will have to chroot into your existing install from live and reinstall glibc & gcc.

    It's a bit of a pain but here is a guide http://linux.about.com/od/ubupck_doc/a/ubupg26t01.htm

    Probably a good thing for any Linux user to know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts