1. #1
    Junior Firefly
    Joined
    Sep 2000
    Location
    Florida
    Posts
    521

    Mapped Network Drive Won't Connect at Startup (Windows 7)

    I've had a Netgear WNDR3700 for a couple weeks and it has a USB port for a network flash drive. For the most part it works fine. But when Windows 7 starts it always says it can't connect to the drive. But if I click on the Drive (:Z) manually it will connect with no issues. Any suggestions? My Mac connects to it with no problems at all (But you don't have to map drives on Macs either). Thanks in advance!

  2. #2
    Veteran Onion
    Joined
    Jul 2001
    Location
    Michigan
    Posts
    4,282

    Re: Mapped Network Drive Won't Connect at Startup (Windows 7)

    Map it via a batch script instead.

    net use drive letter: \\server name\share

    Put the .bat script in your startup folder and have it run every log in.

  3. #3
    Junior Firefly
    Joined
    Sep 2000
    Location
    Florida
    Posts
    521

    Re: Mapped Network Drive Won't Connect at Startup (Windows 7)

    Quote Originally posted by idchoppers View Post
    Map it via a batch script instead.

    net use drive letter: \\server name\share

    Put the .bat script in your startup folder and have it run every log in.
    Thanks a lot. That worked....almost. The problem is that the .bat runs before W7 even knows the drive is there. Is there a way to delay the batch file by maybe 3-4 seconds?

  4. #4
    Junior Firefly
    Joined
    Sep 2000
    Location
    Florida
    Posts
    521

    Re: Mapped Network Drive Won't Connect at Startup (Windows 7)

    Quote Originally posted by wallix View Post
    Thanks a lot. That worked....almost. The problem is that the .bat runs before W7 even knows the drive is there. Is there a way to delay the batch file by maybe 3-4 seconds?
    Got it. I poked around on the net and ended up going wth:

    Code:
    PING 1.1.1.1 -n 1 -w 6000 >NUL
    net use z: \\routerdrive\USB_Storage
    That got me 6 seconds which works fine. Thanks again.

  5. #5
    Super Moderator
    Joined
    Jun 2001
    Location
    Adelaide, Australia
    Posts
    6,555

    Re: Mapped Network Drive Won't Connect at Startup (Windows 7)

    I realise you got your answer but I posted this visual basic script in another thread recently which does the same thing, if you wanted to go that way instead.
    Code:
    Set objNetwork = CreateObject("WScript.Network") 
    wscript.sleep 30000
    objNetwork.MapNetworkDrive "X:" , "\\server\share"

  6. #6
    Omnipotent
    Joined
    Jun 2002
    Location
    UK
    Posts
    30,842

    Re: Mapped Network Drive Won't Connect at Startup (Windows 7)

    I've got a similar issue at work, we map 2 drives on all the PCs linking to two other PCs, it auto connects to one mapped drive (green link), but doesn't on the other (red link), and doesn't do so until we click on it in My Computer.

    We don't get any error or warning message though
    Last edited by LuckyNV; February 7, 2010 at 14:32.

  7. #7
    Junior Firefly
    Joined
    Sep 2000
    Location
    Florida
    Posts
    521

    Re: Mapped Network Drive Won't Connect at Startup (Windows 7)

    Quote Originally posted by scoobs View Post
    I realise you got your answer but I posted this visual basic script in another thread recently which does the same thing, if you wanted to go that way instead.
    Code:
    Set objNetwork = CreateObject("WScript.Network") 
    wscript.sleep 30000
    objNetwork.MapNetworkDrive "X:" , "\\server\share"
    Thanks, I may give this a shot, too, because I spoke too quickly. The batch file only worked about 30% of the time so I just went back to manual. I tried the method to Schedule a re-connect at logon as well (with Task Scheduler) and that didn't work either. It's definitely a W7 issue because, like I mentioned earlier, my Macbook stays connected to it with no problems at all.

  8. #8
    Administrator
    • Computer Specs
      • Motherboard or Laptop:
      • ASROCK Fatal1ty z77 Pro
      • Chipset:
      • Intel P77
      • CPU:
      • Intel i7 2600K
      • CPU Overclock Speed:
      • Stock
      • CPU Cooler:
      • Corsair H50
      • Memory:
      • Corsair Vengeance 16GB
      • Memory Speed:
      • 1600 Mhz
      • Video Card(s):
      • MSI GTX780 6GB
      • Video Card Speed:
      • Stock
      • Sound Card:
      • Soundblaster Z
      • PSU:
      • CM SilentProM 1000
      • Hard Drive(s):
      • 840 Pro + RevoDrive X2
      • Optical Drives:
      • LG Bluray/HD-DVD Combo
      • Operating System:
      • Windows 8.1 x64

    Joined
    Jul 2000
    Location
    UK
    Posts
    15,866

    Re: Mapped Network Drive Won't Connect at Startup (Windows 7)

    Do you have an HP printer at all and have the HP Suite installed? This is what cause the same delay that you're experiencing and removing it and just using the built in 7 drivers resolved the issue for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts